Are you the publisher? Claim or contact us about this channel


Embed this content in your HTML

Search

Report adult content:

click to rate:

Account: (login)

More Channels


Showcase


Channel Catalog


Channel Description:

Latest Forum Threads in SAP on Oracle

older | 1 | .... | 87 | 88 | (Page 89) | 90 | 91 | .... | 95 | newer

    0 0

    Dear all,

     

    One of my SAP user got the below error in SAP PROD server , kindly check below logs .

     

    u201CIRP maximum work process hold time exceed. This may be caused by network problems or slow front-end-systems.u201D

     

    Note : SAP Gui also latest installed , still the user got the above error .

     

    Kindly suggest


    0 0

    Getting the error message "SAP system message No connect to database, session terminated" when connected from GUI.

     

    This second time in last one week.

     

    DB - Oracle 10

    OS - Windows 2008 R2

     

    Oracle and SAP are on the same server and in running state. Oracle listener is running and r3trans gave return code 0000, still none of us are able to connect to server. No network issue and None of the LUNS are SAN disks are altered from storage.

     

    Dev_w0.txt, alert_chq.txt and DB status.JPG are attached for your reference.

     

    Quick help is much appreciated.


    0 0

    Hello,

     

    I´m adjusting some oracle parameters but now I´m with some doubts regarding the log_buffer size value!

     

    This is a production SAP system running on Oracle DB 11.2g (11.2.0.4) in a Windows Server 2012 (R2).

     

    Some questions/doubts:

     

    1. Which unit the log_buffer has? Bytes? (The default value in my database is 14254080).

     

     

    2. I read the sap note 1431798 (Oracle 11.2.0: Database Parameter Settings) and then the sap note 1627481 (Preemptive redolog switches in Oracle 11.2 and higher) and in this last one I read some requirements (my server has 8 cores):

    For systems with <= 16 cores set the logbuffer to 4MB or don't set it at all.

     

    So... I changed the value (consider that parameter is in bytes unit) to 4194304 bytes (4 megabytes)

     

    This is a good decision or not? Tell me your opinion please.

     

     

    3. In the same sap note 1627481 I see the following statement:

    If you have set the logbuffer to 4MB, then create redo logfiles of at least 200MB.This minimum configuration should only be used for DEV, Test or QA systems but not for production systems.

     

    But I don´t understand... as I said before I set the log_buffer to 4MB but now I want to know which value I must set to the redo logfiles (origlogs and mirrlogs) in a production system. As you see the sap note only described the value for DEV, Test or QA systems, not for the production systems.

     

    Which value is recommended for redolog files?

     

     

    Can you answer to these three questions?

    Any other recommendations?

     

     

    Thank you,

    Best regards,

    João Dimas


    0 0

    Hello,

     

    We are changing SAP System SID and Database SID using SWPM.

     

    TS1 is our new SAP and DB SID

     

    In Rename/Config database step, we are getting below error.

     

    An error occurred while processing option System Rename > Central System > SAP System Rename( Last error reported by the step: Error return code. DIAGNOSIS: Return code 14 of executable D:\oracle\TS1\11203/bin/oradim indicates an error. SOLUTION: For more information, see log file oradim.log.). You can now:

    Choose Retry to repeat the current step.

    Choose Log Files to get more information about the error.

    Stop the option and continue later.

     

    oradim.log shows below error message

     

    Instance created.

    DIM-00019: create service error

    O/S-Error: (OS 2) The system cannot find the file specified.

     

     

    sapinst.log shows below error

     

    WARNING 2016-03-25 15:21:59.801 (<Domain>\ts1adm) id=modlib.jslib.childAppReturn

    Execution of the command "D:\oracle\TS1\11203\bin\oradim -NEW -SID TS1 -STARTMODE manual -SRVCSTART system" finished with return code 14. Output:

    Instance created.

    DIM-00019: create service error

    O/S-Error: (OS 2) The system cannot find the file specified.

     

     

    ERROR 2016-03-25 15:21:59.801 (<Domain>\ts1adm) id=ind-rel.ind-os.ora.badReturnCode errno=CJS-00095

    Error return code. DIAGNOSIS: Return code 14 of executable D:\oracle\TS1\11203/bin/oradim indicates an error. SOLUTION: For more information, see log file oradim.log.

     

     

    ERROR 2016-03-25 15:21:59.801 (<Domain>\ts1adm) id=modlib.jslib.caughtException errno=MUT-03025

    Caught ESAPinstJSError in module call: ind-rel.ind-os.ora.badReturnCode.

     

     

    ERROR 2016-03-25 15:21:59.848 (<Domain>\ts1adm) id=controller.stepExecuted errno=FCO-00011

    The step createInstance_oradim with step key |offlineadjustment_dialogs|ind|ind|ind|ind|0|0|offlineadjustment_db_post|ind|ind|ind|ind|db_post|0|ora_clone_db_post_dia|ind|ind|ind|ind|ora|0|ora_clone_obr|ind|ind|ind|ind|oraOBR|0|createInstance_oradim was executed with status ERROR ( Last error reported by the step: Error return code. DIAGNOSIS: Return code 14 of executable D:\oracle\TS1\11203/bin/oradim indicates an error. SOLUTION: For more information, see log file oradim.log.).

     

     

    Request your expertise to resolve it at the earliest.

     

    With Regards,

    Parin Hariyani


    0 0

    Hi,

     

    For OS/DB migration project, it is mandatory to get  "SAP OS DB migration check service".

     

    Can someone please let me know the steps  to get "SAP OS DB migration check service".

     

    I have already checked "SAP OS/DB Migration Check | SAP Support Portal"   but it does give us the steps.

     

    Thanks you.

     

    Best Regards,

    Arpit.


    0 0
  • 03/26/16--11:00: Regarding the Oracle restore
  • Dear Experts,

     

    I have small query on oracle restore using BR TOOLS.

     

     

    we are facing the below issue while restoring the production backup on the quality system.

     

    our production backup location is /oracle/PRD/sapbackup

     

    Quality backup location is /oracle/QRD/SAPBACKUP.

     

    these mounts are not attached to all servers.

     

    we have taken the backup its created three files 1. one folder with all data files.  2 backupprd. log  3. zyx.fnd file

     

    I have moved the above thee files and archive log to target backup folder and renamed the backup<PRD>.log to backup<QRD>.log

     

    Now when i restore on quality system saying that backup files not found... actually its searching the backup on /oracle/PRD/sapbackup from fnd file.

     

    is there any way to avoid it. Or do I need to change path anywhere in backup files

     

    I have seen so many blogs nowhere exact resolution is not mentioned


    Log :


    BR0443W File '/oracle/PRD/sapbackup/besukhbi/sr3.data12.Z' to be restored not found

    BR0443W File '/oracle/PRD/sapbackup/besukhbi/sr3.data13.Z' to be restored not found

    BR0443W File '/oracle/PRD/sapbackup/besukhbi/sr3.data14.Z' to be restored not found

    BR0443W File '/oracle/PRD/sapbackup/besukhbi/sr3.data15.Z' to be restored not found

    BR0443W File '/oracle/PRD/sapbackup/besukhbi/sr3.data16.Z' to be restored not found

    BR0443W File '/oracle/PRD/sapbackup/besukhbi/sr3.data17.Z' to be restored not found

     

    But i have copied the files to /oracle/QRD/sapbackup/besukhbi with full permissions

     

     

     

    Thanks,

    Reddy


    0 0
  • 03/31/16--23:52: BRrecover ASM
  • Has anyone used brrecover utility for system copy from one server another server. Our SAP installation is on Oracle 12c using ASM with Grid on Linux OS. The backup is configured with brtools using RMAN and the full backup executed successfully without any errors. I followed note 1003028 to prepare the restore on the target system and initiated the command 'brrecover -t reset -b last -f <NEW_SID> -u /'. As the intial step, brrecover identified the control file  correctly and restored from the tape into its temporary location '/oracle/<SID>/sapbackup/cntrl<OLD_SID>.dbf. However, it failed with an error when it tried to copy the control file from its temporary location to its permanent location in the ASM. It looks like copy command in asm cannot use the incarnation #s and they should be omitted. However, the copy command is executed by brrecover tool and I am not sure how do I interrupt to make the control file copy execute with correct syntax.

     

    BR0280I BRRESTORE time stamp: 2016-03-31 17:24:37

    BR0407I Restore of database: BX1

    BR0408I BRRESTORE action ID: resvthbh

    BR0409I BRRESTORE function ID: rsb

    BR0449I Restore mode: partial

    BR0411I Database files for restore:

    +DATA/BX1/CONTROLFILE/current.261.907163733=+DATA/BX1/CONTROLFILE/current.261.907163733

    +REDO/BX1/CONTROLFILE/current.256.907163733=+REDO/BX1/CONTROLFILE/current.256.907163733

    BR0419I Files will be restored from backup: besvtffa.anr 2016-03-31

    17:03:42

    BR0416I 1 file found to restore, size 15.766 MB

    BR0424I Files will not be decompressed

    BR0421I Restore device type: rman_util

     

     

    BR0351I Restoring +DATA/BX1/CONTROLFILE/current.261.907163733

    BR0355I from /oracle/BX1/sapbackup/cntrlBX1.dbf ...

    BR0278E Command output of 'ORACLE_SID=+ASM

    ORACLE_HOME=/opt/oracle/product/grid/12102_1601

    /oracle/BX1/121/bin/asmcmd --privilege sysdba cp

    /oracle/BX1/sapbackup/cntrlBX1.dbf

    +DATA/BX1/CONTROLFILE/current.261.907163733':

    copying /oracle/BX1/sapbackup/cntrlBX1.dbf ->

    +DATA/BX1/CONTROLFILE/current.261.907163733

    ASMCMD-8016: copy source '/oracle/BX1/sapbackup/cntrlBX1.dbf' and

    target

    '+DATA/BX1/CONTROLFILE/current.261.907163733' failed

    ORA-15056: additional error message

    ORA-15046: ASM file name '+DATA/BX1/CONTROLFILE/current.261.907163733'

    is not in single-file creation form

    ORA-06512: at "SYS.X$DBMS_DISKGROUP", line 486

    ORA-06512: at line 3 (DBD ERROR: OCIStmtExecute)

    BR0280I BRRESTORE time stamp: 2016-03-31 17:18:11




    0 0
  • 04/01/16--05:50: BR*Tools RMAN_PREP issue
  • Folks,

     

    On our NW 7.4 ABAP system with Oracle 11G we face issues with the RMAN_PREP activity. (We did test this also with the latest version of BR*Tools!)

     

    We use the feature on all of our systems, but only the NW 7.4 ABAP is not functioning properly.

    Backups etc are running fine so hopefully you have some thought that can fix this issue...

     

    Error:

     

    C:\Windows\system32>brbackup -u / -c force -d rman_prep -p initBWO.sap -m ALL

    BR0051I BRBACKUP 7.40 (16)

    BR0055I Start of database backup: besvwfdo.rmp 2016-04-01 14:41:52

    BR0484I BRBACKUP log file: F:\oracle\BWO\sapbackup\besvwfdo.rmp

    BR0477I Oracle pfile D:\oracle\BWO\11204\database\initBWO.ora created from spfile D:\oracle\BWO\11204\database\sp

    fileBWO.ora

     

    BR0280I BRBACKUP time stamp: 2016-04-01 14:41:53

    BR0057I Backup of database: BWO

    BR0058I BRBACKUP action ID: besvwfdo

    BR0059I BRBACKUP function ID: rmp

    BR0110I Backup mode: ALL

    BR0077I Database file for backup: D:\ORACLE\BWO\CNTRL\CNTRLBWO.DBF

    BR0061I 56 files found for backup, total size 510236.570 MB

    BR0143I Backup type: online

    BR0130I Backup device type: rman_prep

    BR0523I Preparation for using RMAN only - no backup

    BR0140I Number of parallel copy processes: 2

    BR0134I Unattended mode with 'force' active - no operator confirmation allowed

     

    BR0525I Preparing backup of F:\ORACLE\BWO\SAPDATA2\BWO_43\BWO.DATA43 using RMAN...

     

    BR0525I Preparing backup of F:\ORACLE\BWO\SAPDATA2\BWO_44\BWO.DATA44 using RMAN...

    BR0278E Command output of 'D:\oracle\BWO\11204\BIN\rman nocatalog':

     

    Recovery Manager: Release 11.2.0.4.0 - Production on Fri Apr 1 14:41:53 2016

     

    Copyright (c) 1982, 2011, Oracle and/or its affiliates.  All rights reserved.

     

    RMAN>

    RMAN> connect target *

    connected to target database: BWO (DBID=2668774452)

    using target database control file instead of recovery catalog

     

    RMAN> **end-of-file**

     

    RMAN>

    host command complete

     

    RMAN> 2> 3> 4> 5> 6>

    allocated channel: sbt

    channel sbt: SID=43 device type=SBT_TAPE

    channel sbt: MMS Version 7.20.36.6

     

    executing command: SET NOCFAU

     

    Starting backup at 2016-04-01 14:41:54

    channel sbt: starting full datafile backup set

    channel sbt: specifying datafile(s) in backup set

    input datafile file number=00042 name=F:\ORACLE\BWO\SAPDATA2\BWO_43\BWO.DATA43

    channel sbt: starting piece 1 at 2016-04-01 14:41:55

    released channel: sbt

    RMAN-00571: ===========================================================

    RMAN-00569: =============== ERROR MESSAGE STACK FOLLOWS ===============

    RMAN-00571: ===========================================================

    RMAN-03009: failure of backup command on sbt channel at 04/01/2016 14:41:56

    ORA-19506: failed to create sequential file, name="besvwfdo.42", parms=""

    ORA-27007: failed to open file

    ORA-19511: Error received from media manager layer, error text:

       SBT error = 7008, errno = 0, sbtopen: i/o error

     

    RMAN>

    specification does not match any backup in the repository

     

    RMAN>

     

    Recovery Manager complete.

    BR0278E Command output of 'BRSBTLIB':

    #LOCK F:\oracle\BWO\sapbackup\.lock.brb

    #CMD brtools -f rmanprep - 20971528192 0

    BR0252E Function CreateProcess() failed for 'brtools -f rmanprep - 20971528192 0' at location BrPipeCreate-9

    BR0253E errno 2: The system cannot find the file specified.

    BR0272E Execution of program 'brtools -f rmanprep - 20971528192 0' through pipe failed

    BR0280I BRSBTLIB time stamp: 2016-04-01 14.41.55

    BR0538E Copying of data by BRSBTLIB failed

    BR0280I BRSBTLIB time stamp: 2016-04-01 14.41.55

    BR0537E BRSBTLIB call sbtopen() failed


    BR0280I BRBACKUP time stamp: 2016-04-01 14:41:57

    BR0279E Return code from 'D:\oracle\BWO\11204\BIN\rman nocatalog': 0

    BR0536E RMAN call for database instance BWO failed

    BR0200I BR_TRACE: location BrRmanCall-62, commands for RMAN in: F:\oracle\BWO\sapbackup\.besvwfdo.000

    @F:\oracle\BWO\sapbackup\..besvwfdo..000

    host 'brtools -f delete F:\oracle\BWO\sapbackup\..besvwfdo..000';

    run { allocate channel sbt device type 'SBT_TAPE'

    parms 'BLKSIZE=65536 ENV=(BR_ORACLE_SID=BWO,BR_ORACLE_HOME=D:\oracle\BWO\11204,BR_ORACLE_BASE=D:\oracle,SAPDATA_H

    OME=F:\oracle\BWO,SAPEXE=E:\usr\sap\BWO\DVEBMGS00\exe)';

    set nocfau;

    backup as backupset full filesperset 9999 diskratio 0 tag besvwfdo format 'besvwfdo.42' check logical

    datafile 'F:\ORACLE\BWO\SAPDATA2\BWO_43\BWO.DATA43';

    release channel sbt; }

    list backup of datafile 42 tag besvwfdo;

    exit;

     

     

    Thanks in advance!


    0 0
  • 02/18/16--22:31: BI Infocube Compress
  • Hi,

     

    When I compress one infocube its showing ora-14080 error.

     

    Please help.


    0 0
  • 04/04/16--02:02: 12c Installation check error
  • Hi All,

     

    I'm preparing for an upgrade of Oracle from 10.2.0.5 to 12.1.0.2 and have run into a little issue.

    I've run the following command line

     

    ./RUNINSTALLER -oracle_base /oracle/SID -tmp /oracle/SID/temp -check

     

    After encountering this error about /tmp free space

     

    Free Space - This is a prerequisite condition to test whether the minimum required free space is available on the file system.

     

    This is a prerequisite condition to test whether sufficient free space is available in the file system. (more details)

    Expected Value

    : 5GB

    Actual Value

    : 644.4023MB

     

    But that didn't work, so I set environment variables $TMP and $TMPDIR as per the documentation from Oracle https://docs.oracle.com/database/121/AXDQI/toc.htm#BABIHAJA and yet it still complains.

     

    Is this a bug or am I doing something wrong here?

     

    Thanks

    Craig


    0 0

    Dear all,

     

     

    Good day..!

     

     

    Recently,The oracle DB version was upgraded from 11.2.0.3 to 11.2.0.4.

     

    Since then the backup started to take more than 24 hours – 48 hours duration and sometimes it hangs. DB Statistics and DB Checks were manually triggered at OS Level daily and even these takes long time.

     

    Usually Backup used to complete within 4-5 hrs before upgrade.

     

    It is impacting day to day transactions and BI chain process badly as Back up is not completing on time.

     

    Kindly guide us to resolve the problem. Thank you.

     

    Best Regards,

    Gopukrish


    0 0

    Hi All,

     

    Afraid it's me again with yet another question.

     

    I have just ran the pre-upgrade checks as per the Upgrade Guide for UNIX and am looking at the resultant log and output.

     

    It's complaining about the processes parameter being too low.

     

                              [Pre-Upgrade Checks]

    **********************************************************************

    WARNING: --> Process Count may be too low

     

         Database has a maximum process count of 192 which is lower than the

         default value of 300 for this release.

         You should update your processes value prior to the upgrade

         to a value of at least 300.

         For example:

            ALTER SYSTEM SET PROCESSES=300 SCOPE=SPFILE

         or update your init.ora file.

    I have checked this parameter against both the 10g note and the 12c note and both say the same thing to calculate as follows :-

     

    processes

    (#ABAP work processes * 2) +
    (#J2EE server processes * <max-connections> ) +
    PARALLEL_MAX_SERVERS + 40

     

    So I double checked this and I get the following ABAP only,

    16 WPs * 2  = 32

    PARALLEL_MAX_SERVERS (CPU Core Count (12) * 10) = 120

    + 40

    So I get 192 which is exactly what is set.


    So why is it complaining about it needing to be at least 300?


    Also things like events and _fix_control amongst others below should these be removed just prior to the upgrade or can these remain and be checked/removed post upgrade?


    _disable_objstat_del_broadcast = FALSE

    _external_scn_rejection_threshold_hours = 24

    _first_spare_parameter = 1

    _fix_control = 13627489:ON, 5099019:ON, 5705630:ON, 5765456:3, 6055658:OFF, 6399597:ON, 6430500:ON, 6440977:ON, 6626018:ON, 6670551:ON, 6972291:ON, 7692248:ON, 7891471:ON, 9196440:ON, 9495669:ON

    _optim_peek_user_binds = FALSE

    _optimizer_mjc_enabled = FALSE

    _sort_elimination_cost_ratio = 10

     

    Thanks

    Craig


    0 0
  • 04/07/16--03:58: BR*Tools 7.40 Error with ora
  • Hi All,

     

    As part of the upgrade to 12c I have installed BR*Tools 7.40 patch 21, created the necessary /oracle/<DBSID>/sapprof directory and copied the profiles into it.

     

    I can run brtools with <sid>adm and check the instance status using brspace -p init<DBSID>.sap -s 20 -l E -u / -f dbshow -c dbstate

    But when I run this with ora<DBSID> I get the following errors :-

    BR0280I BRTOOLS time stamp: 2016-04-07 11:41:39

    BR0663I Your choice: 'c'

    BR0259I Program execution will be continued...

     

     

    BR0291I BRSPACE will be started with options '-p init<DBSID>.sap -s 20 -l E -u / -f dbshow -c dbstate'

     

     

    BR0280I BRTOOLS time stamp: 2016-04-07 11:41:39

    BR0670I Enter 'c[ont]' to continue, 'b[ack]' to go back, 's[top]' to abort:

    c

    BR0280I BRTOOLS time stamp: 2016-04-07 11:41:40

    BR0257I Your reply: 'c'

    BR0259I Program execution will be continued...

     

     

    ###############################################################################

     

     

    exec(): 0509-036 Cannot load program brspace because of the following errors:

    rtld: 0712-001 Symbol modf was referenced

          from module brspace(), but a runtime definition

          of the symbol was not found.

    rtld: 0712-001 Symbol strcat was referenced

          from module brspace(), but a runtime definition

          of the symbol was not found.

    rtld: 0712-001 Symbol strcpy was referenced

          from module brspace(), but a runtime definition

          of the symbol was not found.

    rtld: 0712-001 Symbol strcmp was referenced

          from module brspace(), but a runtime definition

          of the symbol was not found.

    rtld: 0712-001 Symbol strncat was referenced

          from module brspace(), but a runtime definition

          of the symbol was not found.

    rtld: 0712-001 Symbol strncpy was referenced

          from module brspace(), but a runtime definition

          of the symbol was not found.

    rtld: 0712-001 Symbol fsav was referenced

          from module brspace(), but a runtime definition

          of the symbol was not found.

    rtld: 0712-001 Symbol fres was referenced

          from module brspace(), but a runtime definition

          of the symbol was not found.

    rtld: 0712-001 Symbol floor was referenced

          from module brspace(), but a runtime definition

          of the symbol was not found.

    rtld: 0712-001 Symbol ceil was referenced

          from module brspace(), but a runtime definition

          of the symbol was not found.

    rtld: 0712-002 fatal error: exiting.

     

     

    ###############################################################################

     

     

    BR0292I Execution of BRSPACE finished with return code 255

     

    At first I thought the 11g instant client reference was the cause as it was missing in the $LIBPATH environment variable but correcting that hasn't fixed the problem.

     

    The permissions are correct I believe :-

     

    -rwsrwxr--    1 ora<SID>   dba        14856568 05 Mar 21:29 /sapmnt/<SID>/exe/brarchive

    -rwsrwxr--    1 ora<SID>   dba        15027515 05 Mar 21:29 /sapmnt/<SID>/exe/brbackup

    -rwsrwxr--    1 ora<SID>   dba        17619996 05 Mar 21:29 /sapmnt/<SID>/exe/brconnect

    -rwxr-xr-x    1 <SID>adm   sapsys     15734035 05 Mar 21:30 /sapmnt/<SID>/exe/brrecover

    -rwxr-xr-x    1 <SID>adm   sapsys      9175648 05 Mar 20:46 /sapmnt/<SID>/exe/brrestore

    -rwxr-xr-x    1 <SID>adm   sapsys     18491388 05 Mar 21:30 /sapmnt/<SID>/exe/brspace

    -rwxr-xr-x    1 <SID>adm   sapsys     10109828 05 Mar 20:46 /sapmnt/<SID>/exe/brtools

    This was working prior to updating from 720 patch 42 of BR*Tools.

     

    What could be the cause?

     

    Thanks

    Craig


    0 0

    Hello,

     

    how to identify inactive steps in an execution plan in ST04 for Oracle 12c.

     

    i am referring to Stefen's blog post.

     

    http://scn.sap.com/community/oracle/blog/2013/09/24/oracle-db-optimizer-part-vii--looking-under-the-hood-of-adaptive-query-optimization-adaptive-plans-oracle-12c

     

    attached is a screenshot from one of the system, i am working on.

     

    which of the steps are inactive.

     

    11.png

    22.png


    0 0
  • 04/06/16--17:13: Change rman backup retention
  • Hello everyone,

    I am using rman backup with Oracle 11.2.0.3. I am trying to reduce the backup retention from 40 day to 22. I changed parameter "control_file_record_keep_time" both in DB and DB17. I also set expire_period to the same value in initSID.sap. When I run the backup, I get the following error:

     

    BR0187E Value 22 of parameter/option 'control_file_record_keep_time' smaller than 30.

     

    Does anyone know how to fix this?

     

    Thanks


    0 0

    Hello

     

    I noticed while upgrading oracle 11.2 to oracle 12c,we are no more provided an option to disable partitioning while upgrading to Oracle 12c using DBUA

     

    1. Is that correct ? Or there is a way to disable the partitioning  while upgrading oracle to 12c using DBUA ?

     

    2. Also as per one of the notes,it says partitioning is necessary for BI systems, so do we need to have partitioning while upgrading oracle to 12c on

    ECC6 EHP7

    CRM7 EHP3

    SOLUTION MANAGER 7.1 SPS14

     

    Thanks

    Shradha


    0 0

    Hi All

     

    Me yet again.

     

    I have just installed BR*Tools 7.40 as per my previous posting and correcting an issue with it not running for ora<SID> user.

     

    Unbeknown until this morning that as a result of correcting that issue, sqlplus now doesn't work for either <SID>adm or ora<SID> users.

     

    Error is :-

     

    sqlplus -version

    SP2-1503: Unable to initialize Oracle call interface

    SP2-0152: ORACLE may not be functioning properly

     

    Now for the life of me I couldn't figure this out.  For <SID>adm user no environment settings were changed when I patched Oracle from 10.2.0.4 to 10.2.0.5 for prep to 12c and so I was confused as to why it stopped working.  The only thing I changed for ora<SID> user was to add /oracle/client/11x_64/instantclient to the LIBPATH environment variable to get it to work.  Otherwise you get the error I posted before as below.

     

    brspace -p init<SID>.sap -s 20 -l E -u / -f dbshow -c dbstate

    exec(): 0509-036 Cannot load program brspace because of the following errors:

    rtld: 0712-001 Symbol modf was referenced

          from module brspace(), but a runtime definition

          of the symbol was not found.

    rtld: 0712-001 Symbol strcat was referenced

          from module brspace(), but a runtime definition

          of the symbol was not found.

    rtld: 0712-001 Symbol strcpy was referenced

          from module brspace(), but a runtime definition

          of the symbol was not found.

    rtld: 0712-001 Symbol strcmp was referenced

          from module brspace(), but a runtime definition

          of the symbol was not found.

    rtld: 0712-001 Symbol strncat was referenced

          from module brspace(), but a runtime definition

          of the symbol was not found.

    rtld: 0712-001 Symbol strncpy was referenced

          from module brspace(), but a runtime definition

          of the symbol was not found.

    rtld: 0712-001 Symbol fsav was referenced

          from module brspace(), but a runtime definition

          of the symbol was not found.

    rtld: 0712-001 Symbol fres was referenced

          from module brspace(), but a runtime definition

          of the symbol was not found.

    rtld: 0712-001 Symbol floor was referenced

          from module brspace(), but a runtime definition

          of the symbol was not found.

    rtld: 0712-001 Symbol ceil was referenced

          from module brspace(), but a runtime definition

          of the symbol was not found.

    rtld: 0712-002 fatal error: exiting.

    So this is a change to the way BR*Tools used to work it seems.

     

    Now for the problem encountered.

     

    With /oracle/client/11x_64/instantclient added to LIBPATH at the end you still get the above error.  Moving it before /oracle/<SID>/102_64/lib fixes it for user ora<SID>

    However the side affect to this is that sqlplus now no longer functions and you get the error at the start of this thread!


    Now what's strange is that if you unsetenv LIBPATH and replace it with LD_LIBRARY_PATH both programs work.  I know that with AIX 5.3 onwards they use LD_LIBRARY_PATH by default but will also use LIBPATH if set IBM Managing LIBPATH and LD_LIBRARY_PATH environment variables for LSF jobs on AIX5.3 - United States


    However that's not how the .dbenv scripts are written, they explicitly set LIBPATH if it detects AIX.


    Also strange is that I can't run sqlplus any more as the user <SID>adm without again changing LIBPATH and adding in /oracle/<SID>/102_64/lib which again isn't part of the logon scripts.


    So do I replace LIBPATH in those logon scripts with LD_LIBRARY_PATH or what?  What's the consequence of doing that?


    Thanks

    Craig


    0 0

    Hi All,

     

    Me again.

     

    I am now looking at how to upgrade our production environment which uses Oracle Data Guard.

     

    I've read Upgrading Databases in a Data Guard Configuration which applies to 11g but presumably this is also true for 12c?

     

    How do you perform the install on the physical standby? 

    From the document it says shutdown both primary and standby install Oracle on standby then mount the standby database. 

    From SAP perspective presumably before mounting apply SBP's.

    Mount from the new Oracle home?

    Then install and upgrade the primary database and the upgrade will transfer to the standby via the redo logs.

     

    Is it really that simply?

     

    Thanks

    Craig


    0 0

    hi,

     

         can u explain oracle startup and shutdown procedure in sap r/3

     

    thanks in advance...


    0 0
  • 02/18/16--22:31: BI Infocube Compress
  • Hi,

     

    When I compress one infocube its showing ora-14080 error.

     

    Please help.


older | 1 | .... | 87 | 88 | (Page 89) | 90 | 91 | .... | 95 | newer