Are you the publisher? Claim or contact us about this channel


Embed this content in your HTML

Search

Report adult content:

click to rate:

Account: (login)

More Channels


Showcase


Channel Catalog


Channel Description:

Latest Forum Threads in SAP on Oracle

older | 1 | .... | 42 | 43 | (Page 44) | 45 | 46 | .... | 95 | newer

    0 0
  • 10/07/14--04:53: Oracle process
  • Hi team,

     

    Can anyone tell me how can i check oracle related process running on AIX.

     

    I got an altert from oracle team that oracle process is taking more paging space. How can i see that oracle is taking more space on java system.

     

     

    Thanks

    Ramesh


    0 0

    Hi SAP Gurus.

     

    Good day, I'm facing problem when installing SAP ECC 6.0 EHP7 (IDES Version). Its stucked in phase 30 of 35 Check DDIC Password.

     

    Below are the error details:-

     

    ECC Message Box


            Unable to open RFC connection to SAP System ECC. 

    SOLUTION: Start the system.    

     

    Then I checked the SAP MMC Console, disp+work.exe stopped.

     

    Below are the dev_disp developer trace.

     

    ---------------------------------------------------

    trc file: "dev_disp", trc level: 2, release: "741"

    ---------------------------------------------------

    <<- SapSSLSetTraceFile()==SAP_O_K

     

     

    command line arg 0: D:\usr\sap\ECC\DVEBMGS00\exe\disp+work.EXE

    command line arg 1: pf=\\ECC\sapmnt\ECC\SYS\profile\ECC_DVEBMGS00_ECC

     

     

    sysno      00

    sid        ECC

    systemid   562 (PC with Windows NT)

    relno      7410

    patchlevel 0

    patchno    11

    intno      20020600

    make       multithreaded, Unicode, 64 bit, optimized

    profile    \\ECC\sapmnt\ECC\SYS\profile\ECC_DVEBMGS00_ECC

    pid        3948

     

     

    Tue Oct 07 22:07:37 2014

    kernel runs with dp version 197000(ext=117000) (@(#) DPLIB-INT-VERSION-197000-UC)

    length of sys_adm_ext is 500 bytes

    ***LOG Q00=> DpSapEnvInit, DPStart (00 3948) [dpInit.c     574]

    ShmProtect( 5, 3 )

    SigIInit: ok (whoami=1)

    Thread handle for mainthread created

    SigIRegisterRoutine: handler for signal SIGSEGV installed (SigISegv, flag 0)

    Pipe created: \\.\pipe\SAP3948

    SigIInit: Create Message Thread

    SigIRegisterExitRoutine: exithandler installed (DpSigExitHandler)

    SigIRegisterTerminateRoutine: terminatehandler installed (DpSigExitHandler)

      shared lib "dw_xml.dll" version 11 successfully loaded

      shared lib "dw_xtc.dll" version 11 successfully loaded

      shared lib "dw_stl.dll" version 11 successfully loaded

      shared lib "dw_gui.dll" version 11 successfully loaded

      shared lib "dw_mdm.dll" version 11 successfully loaded

      shared lib "dw_rndrt.dll" version 11 successfully loaded

      shared lib "dw_abp.dll" version 11 successfully loaded

    RqQGetMultiCastAddress: Using 224.0.0.129 as IP v4 multicast address

    DpCheckMulticast: check of IP v4 multicast address o.k.

    mshost: >ECC<

    DpSetCancelStrat: set timeout/repetition 0/-1 at level 0

    DpSetCancelStrat: set timeout/repetition 5/-1 at level 1

    DpSetCancelStrat: set timeout/repetition -1/5 at level 2

    rdisp/softcancel_sequence :  -> 0,5,-5

    softcancel_sequence: >0,5,-5<

    use internal message server connection to port 3901

    msserv: >3901<

    dp_bufreftime: 120 sec

    dp_btctime: 0 sec

    dp_autoabaptime: 0 sec

    dp_bgrfc_watchdog_time: 300 sec

    dp_autothtime: 60 sec

    dp_autojavatime: 60 sec

    dp_autoccmstime: 60 sec

    max_dynamic_wp_alive_time: 300 sec

    dp_startup_time: 20

    dp_noptime: 0 sec

    dp_keepalive: 1200 sec

    dp_keepalive_timeout: 60 sec

    dp_ms_keepalive: 60 sec

    dp_ms_keepalive_timeout: 300 sec

    switch off dp-keep-alive for old temus

    dp_spoolalrm: 60 sec

    dp_softcancel_timeout: 5 sec

    rdisp/wp_restart_interval : 300 sec

    DpISetTrcLog: trc logging active, max size = 52428800 bytes

    rdisp/shutdown/load_balance_wait_time: 180 sec

    rdisp/shutdown/disable_login : 0

    rdisp/shutdown/auto_logout: 300 sec

    rdisp/shutdown/trigger_timeout: 180 sec

    rdisp/shutdown/idle_wp_timeout: 60 sec

    rdisp/shutdown/longrunner_timeout: 86400 sec

    rdisp/shutdown/j2ee_timeout: 60 sec

    rdisp/high_load_quota: (load / queue quota) = (90.000000 / 5.000000)

    rdisp/snapshot(CREATE): DP_CS_RESOURCES_EXHAUSTED

    rdisp/snapshot(PERIOD):300 sec

    rdisp/snapshot(LINES):10000 lines

    DpSetAvoidTraceInSignalHandler: 0 -> 1

    DpCommonParamInit: rdisp/core_file_size = default --> no change

    NiSrvLGetServNo: got service name 'sapdp00' from operating system

    NiIGetServNo: servicename 'sapdp00' = port 3200

    NiSrvLGetServNo: got service name 'sapgw00' from operating system

    NiIGetServNo: servicename 'sapgw00' = port 3300

    NiMyHostName: hostname = 'ECC'

    NiHLGetNodeAddr: got hostname 'ECC' from operating system

    NiIGetNodeAddr: hostname 'ECC' = addr 192.168.2.1

    NiHLGetHostName: found address 192.168.2.1 in cache

    NiIGetHostName: addr 192.168.2.1 = hostname 'ECC' (fq)

    Tue Oct 07 22:08:01 2014

    NiHLGetNodeAddr: hostname 'www.doesnotexist0220.qqq.nxst' not found by operating system

    *** WARNING => DpNetCheck: NiHostToAddr(www.doesnotexist0220.qqq.nxst) took 24 seconds

    Tue Oct 07 22:08:17 2014

    NiHLGetHostName: address 1.0.0.1 not found by operating system

    *** WARNING => DpNetCheck: NiAddrToHost(1.0.0.0) took 16 seconds

    NiSrvLGetServNo: got service name 'http' from operating system

     

     

    Looking forward for your replies.

     

    Regards,

    Jay

    -96-


    0 0

    Hello All,

     

    We would like to know what is the best practice to have 4 sapdata or 10 sapdata for Oracle filesystem and distribution of data files.

     

    We have a ECC of 18TB and BW of 25 TB on AIX 6.1 and Oracle 11.2.0.3. I am looking for long term recommendation for filesystem layout of sapdata.

     

    Having 10 or more sapdata for a 10 TB size database would allow parallel read from the 10 different sapdata filesystem.

     

    does anybody have any recommendation for the same.

     

     

    Thanks,

    Dnyandev Kondekar


    0 0


    Hi,

     

    DBTABLOG table has big size log entries & took much time to export hence I would like to exlude the data while importing to mimimize import time.

     

    How can I exclude it at the starting of import?

     

     

    Regards,

    Darshan


    0 0

    Hello Team,

     

    We created the clone of system A on By cloning using Hyper V export/import option.

    Later we changed the all mount points pointing to B.We have now database Oracle 11.2.0.4 OS Linux RHEL 6.0 after cloning. And SAp is ECC 6.0 EHP 7 ,SAP_BASIS 740.Now we are running SWPM 1.0 Sp06 patch3 to rename the SID from A to B.

     

    We encountered the below error

    "An error occurred while processing option System Rename > Standard

    System > SAP System Rename( Last error reported by the step: The JVMreports an exception during execution of class com.sap.sdt.ins.component.ora_clone_db_post_dia.DiSchemaUsersAndListener_validator) and function executeStepClass.\n DIAGNOSIS: The reported error

    messagefrom JVM is: com.sap.sdt.sltoolbox.kdb.KdbException: no server version found in /oracle/B/11204 at


    We can start our database and we also installed oracle 11.2.0.4 on B server on path /oracle/B /11204 again

    still SWPM is giving same error.Please suggest.


    0 0

    Hi,

     

    We are facing an issue regarding an event triggered job SAP_CCMS_MONI_BATCH_STARTUP_DP.

     

    Details of the job

    -


    ABAP Program -> RSAL_BATCH_TOOL_STARTUPDISP

    User -> DDIC

    Job Frequency -> Event Periodic

    Event -> SAP_MONITORING_STARTUP_DISPATCH

     

     

    We performed Database Refresh and this job has come from Source System. We have deleted the job in Target System but after that also we are getting continuous error message in SM21.

     

    Error message is as follows:

     

    14:33:36 DIA  001 000 SAPSYS                EA  S Failed to reschedule a periodic job

    14:33:36 DIA  001 000 SAPSYS                EB  C > Job SAP_CCMS_MONI_BATCH_STARTUP_DP

     

    On digging down we got the below information in SM21 regarding the error:

     

    Documentation for system log message EA S :

    -


    This message is output by one of the job schedulers active in the

    system (e.g. time or event-based scheduler). It indicates a problem

    related to the database. An attempt was made to reschedule a periodic

    job and write the respective control data in the database. This error

    occurred for one of the associated database operations (for example,

    INSERT or UPDATE).

    Another cause of the error is failure to generate a new job ID number.

    A subsequent message will point this out.

    The following courses of action are possible:

    Check whether there are any other notes on this problem next to this

    message in the system log, for example direct messages from the

    database interface. These details generally bring you closer to the

    actual cause of the problem.

    The additional information for this message contains the name of the

    database table for which the error occurred.

    If you determine that the error occurred during the SELECT access to

    table TBTCI, the internal report belonging to this background job has

    been deleted. In this case, there is normally a background job in the

    'terminated' status, which ended due to runtime error

    'LOAD_PROGRAM_NOT_FOUND'. Delete this job to prevent further

    unnecessary scheduling on the part of the background processing

    scheduler. You must then reschedule the job concerned.

    As rescheduling of the periodic job could not be completed

    successfully, this job is not executed at first. The background

    processing scheduler takes this job and attempts to schedule it again.

    Depending on the repetition period, gaps in running the background jobs

    can occur for successful scheduling (i.e. the background jobs that were

    unsuccessfully scheduled will be missing in the job overview if their

    execution date elapsed in the meantime).

    Since the next start of the periodic job could not be scheduled

    correctly, there is no entry in the job overview for the planned start

    date.

    If the system failed to generate the job ID number, you will find notes

    on what to do next in the long text of the respective system log

    message.

     

     

    We have fixed also Background Object in SM61.

     

     

    Kindly help to fix this issue. Looking forward for reply.

     

     

    Thanks,

    Soumya


    0 0
  • 10/08/14--09:53: DB13 offline backup error
  • Dear Experts,

     

     

    I have upgraded the Oracle 10g to 11g after that Offline backup was failing,but online with redo-logs was successful.

     

    Please suggest i have been trying to sort it out since 3 days.db13.jpg


    0 0

    Hi All,

     

     

     

    What are the pros and cons while buying SAP with Oracle DB licensed under ASFU or FU?

     

     

     

    ASFU – Application specific full use

    FU    - Full Use

     

     

     

    Heard there is another licensing option ESL – Embedded Software License for Oracle. Is it available while buying SAP? Or Is it same as ASFU?

     

    Thanks


    0 0

    Hello,

     

    we have problems with bitmap index like in Note 2017734 ORA-14646 and ORA-14400 on BW load run:

    INSERT INTO "/BIC/FZIC_C04" VALUES(:A0 ,:A1 ,:A2 ,:A3 ,:A4 ,:A5 ,:A6 ,:A7 ,:A8 ,:A9 ,:A10 ,:A11 ,:A1\

    aborts with

    B  ***LOG BY4=> sql error 14400  performing INS on table /BIC/FZIC_C04                  [dbtran       7634]

    B  ***LOG BY0=> ORA-14400: inserted partition key does not map to any partition [dbtran       7634]

     

    We rebuild the indexes via RSA like stated in the note, no change. So we we opened a message in which is stated:

     

    A)Drop any bitmap indexes defined on the table, and re-create them on

    the operation is complete.

    B)Mark all index fragments of all bitmap indexes defined on the table

    UNUSABLE and rebuild them once the operation is complete.

     

    It's not stated how, only a link to

    ORA-14646 during oracle compression in BW system

    and

    Compress individual Table Partition with local ... | Oracle Community

    Thats ok, but we don't know how to build the statement and SAP is unwilling to tell us.

     

     

    Any help appreciated

     

    thanks

     

    Jan


    0 0

    Dear Experts,

     

         I have a confusion regarding the system refresh from Prod to QA. I have backup of our production system dated 5th Oct that is to be restored to QA.

    Now if we restore the offline backup onto QA system then how we should generate the control file?

     

    My understanding, start the database (target system, QA) to no mount stage and then give the command alter database backup controlfile to trace.

    Then we edit the trace file

     

    Remove all lines before "STARTUP MOUNT" line. Delete all commented "#" lines. Also remove all lines after CHARACTER SET UTF8;" line.

    Change all Source SOR SID to TAR SID

    Change the line

    CREATE CONTROLFILE REUSE DATABASE ‘TAR’ NORESETLOGS ARCHIVELOG;

    As follow

    CREATE CONTROLFILE REUSE SET DATABASE ‘SOR’ RESETLOGS ARCHIVELOG;

     

    After this we give the command alter database open resetlogs.

     

    Is my understanding correct?

     

    Regards

    Sushant


    0 0
  • 10/09/14--09:09: SAP release and patch level
  • Hi SAP Gurus,

     

    Good day all, how to check SAP release and patch level in SAP ECC? Is there any tcode or programs?

     

    Looking forward for your reply.

     

    Regards,

    Jay

    -96-


    0 0

    Hi SAP Gurus,

     

    Good day all, I have question regarding client copy using export and import method.

    Can copy client from ECC 6.0 (source) to ECC 6.0 EHP 7 (target)?

     

    Looking forward for your reply.

     

    Regards,

    Jay

    -96-


    0 0

    Hi SAP Gurus,

     

    Good day all, I'm facing issue when installing ECC 6.0 EHP7 (IDES Version) in Window 64 bit at phase 20 of 34 (Import ABAP).

     

    Message Box:-

     

    An error occurred while processing optionSAP Business Suite 7i 2013 Support Release 1 > EHP7 for SAP ERP 6.0 ABAP Support Release 1 > Oracle > SAP Systems > Application Server ABAP > Standard System > Standard System( Last error reported by the step: Program 'Migration Monitor' exits with error code 103. For details see log file(s) import_monitor.java.log, import_monitor.log.). You can now:

    • Choose
    • Choose
    • Stop the option and continue later.

    Log files are written to C:\Program Files/sapinst_instdir/BS2013/BS2013SR1/ERP607SR1/ORA/INSTALL/STD/ABAP.

     

    The listener was stated but the status in unknown.       

    Capture01.PNG

     

    Looking forward for your reply.

     

    Regards,

    Jay

    -96-


    0 0

    Hi,

     

    I have upgraded to oracle version 11.2.0.4.0 recently. After upgrade I receive "ORA-1652: Unable to extend temp segment by 128 in tablespace PSAPTEMP" everyday in database check log. There is sufficient space for PSAPTEMP and the status of tablespace in RZ20 is green. I have checked with SQL command "select inst_id, tablespace_name, total_blocks, used_blocks, free_blocks from gv$sort_segment" which returns that there are free blocks available upto 3 Gb.

     

    When I checked tablespace status with BRTOOLS, it shows used space is 0%.

     

     

    Could anyone tell me how to correct this alert message???

     

     

    Thanks and regards,

     

    Ganesan


    0 0

    Hi SAP Gurus,

     

    Good day all, I want to know the difference between SAP Standard and Maintenance license in ECC.

    Which one of the license used for IDES system?

     

    Looking forward for your reply.

     

    Regards,

    Jay

    -96-


    0 0

    Hi,

     

    I need to reorg a table because it is a top in wasted space:

     

    SELECT * FROM

    (SELECT

        SUBSTR(TABLE_NAME, 1, 21) TABLE_NAME,

        NUM_ROWS,

        AVG_ROW_LEN ROWLEN,

        BLOCKS,

        ROUND((AVG_ROW_LEN + 1) * NUM_ROWS / 1000000, 0) NET_MB,

        ROUND(BLOCKS * (8000 - 23 * INI_TRANS) *

          (1 - PCT_FREE / 100) / 1000000, 0) GROSS_MB,

        ROUND((BLOCKS * (8000 - 23 * INI_TRANS) * (1 - PCT_FREE / 100) -

          (AVG_ROW_LEN + 1) * NUM_ROWS) / 1000000) "WASTED_MB"

      FROM DBA_TABLES

      WHERE

        NUM_ROWS IS NOT NULL AND

        OWNER LIKE 'SAP%' AND

        PARTITIONED = 'NO' AND

        (IOT_TYPE != 'IOT' OR IOT_TYPE IS NULL)

      ORDER BY 7 DESC)

    WHERE ROWNUM <=50; 

     

    TABLE_NAME                                                        NUM_ROWS     ROWLEN     BLOCKS     NET_MB   GROSS_MB  WASTED_MB

    ---------------------------------------------------------------                            ---------- ---------- ---------- ---------- ---------- ----------

    EDI40                                                                              63643300       3904   61161993     248527     439100          190573

     

     

    I reorged this table to another tablespace with brspace, then reorged it back to PSAPSR3, and the WASTED_MB in this query stayed exactly the same.

     

    I did some reading and it seems that the reason is that this table contains a BLOB:

     

    SQL> desc sapsr3.EDI40;

    Name Null?    Type

    ----------------------------------------------------------------------------------- -------- --------------------------------------------------------

    MANDT NOT NULL VARCHAR2(9)

    DOCNUM NOT NULL VARCHAR2(48)

    COUNTER NOT NULL VARCHAR2(9)

    PAGENO NOT NULL NUMBER(5)

    TIMESTMP NOT NULL VARCHAR2(138)

    PAGELG NOT NULL NUMBER(5)

    VARDATA BLOB


    The CLOB column size of this table is 350 GB:

     

    SQL> select

      2 l.segment_name,

      3 l.column_name,

      sl.segment_type,

      4 5    sl.bytes as gig

    from

      dba_lobs l,

      6 7    8    dba_segments sl

      9  where

    10    l.owner = 'SAPSR3' and

    11 l.table_name = 'EDI40' and

    12 sl.owner=l.owner and

    13 sl.segment_name in (l.segment_name, l.index_name)

    14  union (

    15  select

    16 segment_name,

    17    null,

    18 segment_type,

    19 sum(bytes)/(1024*1024) GIG

    20  from

    21 dba_segments

    where

      owner = 'SAPSR3' and

      segment_name = 'EDI40' and

    22   23 24   25    segment_type in ('TABLE','TABLE PARTITION')

    26  group by

    27 segment_name,

      segment_type

    );

    28   29

     

    SEGMENT_NAME COLUMN_NAME SEGMENT_TYPE GIG

    ------------------------------ --------------- ------------------ ----------

    EDI40                                                        TABLE     348998

    SYS_LOB0000368442C00007$$ VARDATA LOBINDEX 65536

    SYS_LOB0000368442C00007$$ VARDATA LOBSEGMENT 131072



    Refer to SAP note 646681 and in particular, the section regarding reorganization of tables with LONG fields. In short, you must [STOP SAP]; then 1) generate the ddl for these tables, 2) export their contents to a file, 3)drop them, 4)re-create them with the ddl statements, 6) import the data back into them, 7) re-create their indexes and 8) check their statistics.


    Is the process the same for BLOB? To reclaim the wasted space in this table, is this what is needed to be done?


    Thanks,

    Willem




    0 0


    We have just noe upgrade the kernel and unable to start disp+work process.

     

     

    We are in the middle of upgrade. Quick help is really appreciated.

     

    The dev_w0 log is as below....

     

    ---------------------------------------------------

    trc file: "dev_w0", trc level: 1, release: "720"

    ---------------------------------------------------

    *

    *  ACTIVE TRACE LEVEL           1

    *  ACTIVE TRACE COMPONENTS      all, MJ

    *

    M sysno      20

    M sid        CHQ

    M systemid   562 (PC with Windows NT)

    M relno      7200

    M patchlevel 0

    M patchno    500

    M intno      20020600

    M make       multithreaded, Unicode, 64 bit, optimized

    M profile    D:\usr\sap\CHQ\SYS\profile\CHQ_DVEBMGS20_ABTMSSDQ01

    M pid        4020

    M

    M  kernel runs with dp version 139000(ext=120000) (@(#) DPLIB-INT-VERSION-139000-UC)

    M  length of sys_adm_ext is 588 bytes

    M  ***LOG Q0Q=> tskh_init, WPStart (Workp. 0 4020) [dpxxdisp.c   1381]

    I  MtxInit: 30000 0 0

    M  DpSysAdmExtCreate: ABAP is active

    M  DpSysAdmExtCreate: VMC (JAVA VM in WP) is not active

    M  DpIPCInit2: read dp-profile-values from sys_adm_ext

    M  DpShMCreate: sizeof(wp_adm)  42864 (2256)

    M  DpShMCreate: sizeof(tm_adm)  5517056 (27448)

    M  DpShMCreate: sizeof(wp_ca_adm)  64000 (64)

    M  DpShMCreate: sizeof(appc_ca_adm) 64000 (64)

    M  DpCommTableSize: max/headSize/ftSize/tableSize=500/16/1384064/1384080

    M  DpShMCreate: sizeof(comm_adm)  1384080 (2744)

    M  DpSlockTableSize: max/headSize/ftSize/fiSize/tableSize=0/0/0/0/0

    M  DpShMCreate: sizeof(slock_adm)  0 (296)

    M  DpFileTableSize: max/headSize/ftSize/tableSize=0/0/0/0

    M  DpShMCreate: sizeof(file_adm)  0 (80)

    M  DpShMCreate: sizeof(vmc_adm)  0 (2160)

    M  DpShMCreate: sizeof(wall_adm)  (41664/42896/64/192)

    M  DpShMCreate: sizeof(gw_adm) 48

    M  DpShMCreate: sizeof(j2ee_adm) 3952

    M  DpShMCreate: SHM_DP_ADM_KEY  (addr: 000000000FBC0050, size: 7174832)

    M  DpShMCreate: allocated sys_adm at 000000000FBC0060

    M  DpShMCreate: allocated wp_adm_list at 000000000FBC30B0

    M  DpShMCreate: allocated wp_adm at 000000000FBC32A0

    M  DpShMCreate: allocated tm_adm_list at 000000000FBCDA20

    M  DpShMCreate: allocated tm_adm at 000000000FBCDA70

    M  DpShMCreate: allocated wp_ca_adm at 0000000010110980

    M  DpShMCreate: allocated appc_ca_adm at 0000000010120390

    M  DpShMCreate: allocated comm_adm at 000000001012FDA0

    M  DpShMCreate: system runs without slock table

    M  DpShMCreate: system runs without file table

    M  DpShMCreate: allocated vmc_adm_list at 0000000010281C40

    M  DpShMCreate: system runs without vmc_adm

    M  DpShMCreate: allocated gw_adm at 0000000010281CF0

    M  DpShMCreate: allocated j2ee_adm at 0000000010281D30

    M  DpShMCreate: allocated ca_info at 0000000010282CB0

    M  DpShMCreate: allocated wall_adm at 0000000010282D40

    M  DpCommAttachTable: attached comm table (header=000000001012FDA0/ft=000000001012FDB0)

    M  DpRqQInit: use protect_queue / slots_per_queue 0 / 2001 from sys_adm

    M  rdisp/queue_size_check_value :  -> on,50,30,40,500,50,500,80

    X  EmInit: MmSetImplementation( 2 ).

    X  MM global diagnostic options set: 0

    X  <ES> client 0 initializing ....

    X  <ES> EsILock: use spinlock for locking

    X  Using implementation view

    X  <EsNT> Using memory model view.

    M  <EsNT> Memory Reset disabled as NT default

    X  ES initialized.

    X  mm.dump: set maximum dump mem to 192 MB

    X  mm.dump: set global maximum dump mem to 192 MB

    X  EsRegisterEmCheck: Register EmGetEsHandles at 0000000141915AD0

    M  DpVmcSetActive: set vmc state DP_VMC_NOT_ACTIVE

    M Sat Oct 11 14:07:16 2014

    M  ThStart: taskhandler started

    M  ThInit: initializing DIA work process W0

    M Sat Oct 11 14:07:20 2014

    M  ThInit: running on host ABTMSSDQ01

    M Sat Oct 11 14:07:24 2014

    M  calling db_connect ...

    B  Loading DB library 'D:\usr\sap\CHQ\DVEBMGS20\exe\dboraslib.dll' ...

    B  Library 'D:\usr\sap\CHQ\DVEBMGS20\exe\dboraslib.dll' loaded

    B  Version of 'D:\usr\sap\CHQ\DVEBMGS20\exe\dboraslib.dll' is "720.00", patchlevel (0.425)

    C  Prepending D:\usr\sap\CHQ\DVEBMGS20\exe to Path.

    C  Register application info.

    C  Oracle client version: 10.2.0.4.0, (dbsl 720 090813, UNICODE[2])

    C  Detailed Oracle client (patch) info not available.

    C  Client NLS setting (by OCINlsGetInfo(con=0)): 'AMERICAN_AMERICA.UTF16'

    C  Logon as OPS$-user to get SAPSR3's password

    C  Connecting as /@CHQ on connection 0 (nls 0) ... (dbsl 720 090813, UNICODE[2])

    C  Attaching to database server CHQ (con=0, svchp=07826198, srvhp=078271B8)

    C Sat Oct 11 14:07:25 2014

    C     OCIServerAttach(OCI_DEFAULT) failed with SQL error 12541:

    C     ORA-12541: TNS:no listener                                                                                                   

    C  *** ERROR => CONNECT failed with sql error '12541'

    [dbsloci.c    15455]

    C  SAPUSER error or connect error 99=DBSL_ERR_DB, oerr=12541.

    B  ***LOG BY2=> sql error 12541  performing CON [dbsh         1246]

    B  ***LOG BY0=> ORA-12541: TNS:no listener [dbsh         1246]

    B  ***LOG BY2=> sql error 12541  performing CON [dblink       544]

    B  ***LOG BY0=> ORA-12541: TNS:no listener [dblink       544]

    M  ***LOG R19=> ThInit, db_connect ( DB-Connect 000256) [thxxhead.c   1513]

    M  in_ThErrHandle: 1

    M  *** ERROR => ThInit: db_connect (step 1, th_errno 13, action 3, level 1) [thxxhead.c   11422]

    M  Info for wp 0

    M    pid = 4020

    M    severity = 0

    M    status = 0

    M    stat = WP_NEW

    M    waiting_for = NO_WAITING

    M    reqtype = DP_RQ_DIAWP

    M    act_reqtype = NO_REQTYPE

    M    req.req_info =

    M    req.tid = -1

    M    req.uid = 4294967295

    M    req.mode = 255

    M    req.len = 0

    M    req.rq_id = 65535

    M    req.rq_source =

    M    last_tid = 0

    M    last_uid = 0

    M    last_mode = 0

    M    locked semaphores (), locking ()

    M    act_cs_count = 1

    M    csTrack = 0

    M    csTrackRwExcl = 0

    M    csTrackRwShrd = 0

    M    mode_cleaned_counter = 0

    M    control_flag = 0

    M    int_checked_resource(RFC) = 0

    M    ext_checked_resource(RFC) = 0

    M    int_checked_resource(HTTP) = 0

    M    ext_checked_resource(HTTP) = 0

    M    report = >                                        <

    M    action = 0

    M    tab_name = >                              <

    M    attachedVm = no VM

    M  ThIErrHandle: current request:

    M  -IN-- sender_id ?                 tid  -1    wp_ca_blk   -1      wp_id -1

    M  -IN-- action    -                 uid  -1    appc_ca_blk -1      type  -   

    M  -IN-- new_stat  NO_CHANGE         mode 255   len         0       rq_id -1

    M  *****************************************************************************

    M  *

    M  *  LOCATION    SAP-Server ABTMSSDQ01_CHQ_20 on host ABTMSSDQ01 (wp 0)

    M  *  ERROR       ThInit: db_connect

    M  *

    M  *  TIME        Sat Oct 11 14:07:25 2014

    M  *  RELEASE     720

    M  *  COMPONENT   Taskhandler

    M  *  VERSION     1

    M  *  RC          13

    M  *  MODULE      thxxhead.c

    M  *  LINE        11703

    M  *  COUNTER     1

    M  *

    M  *****************************************************************************

    M  PfStatDisconnect: disconnect statistics

    M  Entering TH_CALLHOOKS

    M  ThCallHooks: call hook >ThrBtcCallLgCl< for event BEFORE_DUMP

    M  ThCallHooks: hook >ThrBtcCallLgCl< o.k.

    M  ThCallHooks: call hook >ThrSaveSPAFields< for event BEFORE_DUMP

    M  *** ERROR => ThrSaveSPAFields: no valid thr_wpadm [thxxrun1.c   867]

    M  *** ERROR => ThCallHooks: event handler ThrSaveSPAFields for event BEFORE_DUMP failed [thxxtool3.c  303]

    M  ThIErrHandle: entering ThSetStatError

    M  ThIErrHandle: do not call ThrCoreInfo (no_core_info=0, in_dynp_env=0)

    M  Entering ThReadDetachMode

    M  call ThrShutDown (1)...

    M  ***LOG Q02=> wp_halt, WPStop (Workp. 0 4020) [dpnttool.c   339]


    0 0

    Dear All,

     

    We have distributed environment and we have recently moved hardware. There were no changes technically, although we are facing below resepctive problem while performing redo log backups.

    Redo log Backups are running, respective below error is occurring at the time of deletion of old redo logs.

     

    Error -

    BR0252E Function remove() failed for '/oracle/SID/oraarch/SIDarch1_586_859154667.dbf' at location BrFileDelete-1

    BR0253E errno 13: Permission denied

     

     

    As per SAP note 113747 - Owners and authorizations for BR*Tools

    We checked and set respective permissions although the problem persists on DB node.

     

    BR* files under Folder /sapmnt/SID/exe --

    >>> ll br*

    -rwsrwxr-x 1 orasid sapsys  9388559 Mar  5  2014 brarchive

    -rwsrwxr-x 1 orasid sapsys  9506369 Mar  5  2014 brbackup

    -rwsrwxr-x 1 orasid sapsys 11409480 Mar  5  2014 brconnect

    -rwxr-xr-x 1 sidadm sapsys  9960982 Mar  5  2014 brrecover

    -rwxr-xr-x 1 sidadm sapsys  6178431 Mar  5  2014 brrestore

    -rwxr-xr-x 1 sidadm sapsys 11846656 Mar  5  2014 brspace

    -rwxr-xr-x 1 sidadm sapsys  6777151 Mar  5  2014 brtools


    We have standalone gateway on DB node of cluster/distributed environment and as i See we have files created with respective SIDadm user of gateway in saparch folder.


    For example -

    -rw-r--r-- 1 gwpadm sapsys   11814 Oct 10 13:51 aeoxxgmx.cds

    -rw-r--r-- 1 gwpadm sapsys   13210 Oct 10 15:08 aeoxxkkz.cds

    -rw-r--r-- 1 gwpadm sapsys   16597 Oct 11 08:05 aeoybcsn.cds

    -rw-r--r-- 1 gwpadm sapsys   26452 Oct 12 08:06 aeoygano.cds

     

    snipnet of /etc/group under DB host

    as i suspect there might be permissions issues , so I have added gwpadm to both group dba and sapsys along with orasid, sidadm, and sjpadm which is a java addin installation.

     

    dba:!:108:oracle,sidadm,sjpadm,lyceus,gwpadm,orasid

    sapinst:!:1000:root,sapadm,sidadm,daaadm,sjpadm,sm1adm,orasid,da1adm,gwpadm

    sapsys:!:1001:lyceus,orasid,gwpadm,sidadm,sjpadm

    oper:!:1002:sidadm,sjpadm,orasid,gwpadm

    lyceus:!:1004:lyceus,sapsys,dba

     

    May I know where I can see , using which user redo log are getting deleted and I have tried deleting manually using all users ( sidadm, orasid, gwpadm, sjpadm) all users can delete redo log files successfully.

     

    appreciate point to focus here.

     

    Thanks,

    Bond


    0 0

    Hi,

    i did a Upgrade of Linux (SLES10 -> SLES11) and Oracle (10.2.xx -> 11.2.0.3).

    Now i have the Problem that brconnect did not work with <sid>adm

     

    as User: <SID>adm

     

    brconnect

    brconnect: error while loading shared libraries: libclntsh.so.11.1: cannot open shared object file: No such file or directory

     

     

    LD_LIBRARY_PATH=/usr/sap/<SID>/SYS/exe/run:/oracle/client/11x_64

     

    ls -la /oracle/client/11x_64/libclntsh.so.11.1

    -rw-r--r-- 1 ora<SID> dba 52761218 Sep 17  2011 /oracle/client/11x_64/libclntsh.so.11.1

     

    ls -la /usr/sap/<SID>/SYS/exe/run/brconnect

    -rwsrwxr-x 1 ora<SID> sapsys 11530700 Nov 20 20:23 /usr/sap/<SID>/SYS/exe/run/brconnect

     

    id

    uid=3214(<SID>adm) gid=200(sapsys) groups=200(sapsys),201(dba),206(oper),1000(sapinst)

     

     

    But brtools works als <SID>adm

     

    brtools

    BR0651I BRTOOLS 7.20 (35)

     

     

     

    pwd

    /oracle/client/11x_64

     

    genezi -v

    Client Shared Library 64-bit - 11.2.0.3.0

     

    System name:    Linux

    Release:    3.0.76-0.11-default

    Version:    #1 SMP Fri Jun 14 08:21:43 UTC 2013 (ccab990)

    Machine:    x86_64

     

    Operating in Instant Client mode.

    Small timezone file = timezone_14.dat

    Large timezone file = timezlrg_14.dat

     

     

     

    cd /sapmnt/WAQ/exe

     

    ls -la dboraslib.so

    -rwxrwxr-x 1 <SID>adm sapsys 1364366 Jan 11 00:32 dboraslib.so

     

    ldd dboraslib.so

        linux-vdso.so.1 =>  (0x00007fff6c5f3000)

        libdl.so.2 => /lib64/libdl.so.2 (0x00007fea3d1c4000)

        librt.so.1 => /lib64/librt.so.1 (0x00007fea3cfba000)

        libclntsh.so.11.1 => /oracle/client/11x_64/libclntsh.so.11.1 (0x00007fea3a729000)

        libc.so.6 => /lib64/libc.so.6 (0x00007fea3a3b2000)

        libstdc++.so.6 => /usr/lib64/libstdc++.so.6 (0x00007fea3a0ab000)

        libm.so.6 => /lib64/libm.so.6 (0x00007fea39e32000)

        libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x00007fea39c1c000)

        libpthread.so.0 => /lib64/libpthread.so.0 (0x00007fea399fe000)

        /lib64/ld-linux-x86-64.so.2 (0x00007fea3d9b8000)

        libnnz11.so => /oracle/client/11x_64/libnnz11.so (0x00007fea39632000)

        libnsl.so.1 => /lib64/libnsl.so.1 (0x00007fea3941a000)

        libaio.so.1 => /lib64/libaio.so.1 (0x00007fea39217000)

     

     

    ldd brconnect

        linux-vdso.so.1 =>  (0x00007fff9ffff000)

        libdl.so.2 => /lib64/libdl.so.2 (0x00007f0ce4cd8000)

        librt.so.1 => /lib64/librt.so.1 (0x00007f0ce4ace000)

        libclntsh.so.11.1 => /oracle/client/11x_64/libclntsh.so.11.1 (0x00007f0ce223d000)

        libpthread.so.0 => /lib64/libpthread.so.0 (0x00007f0ce2020000)

        libstdc++.so.6 => /usr/lib64/libstdc++.so.6 (0x00007f0ce1d19000)

        libm.so.6 => /lib64/libm.so.6 (0x00007f0ce1aa0000)

        libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x00007f0ce188a000)

        libc.so.6 => /lib64/libc.so.6 (0x00007f0ce1512000)

        /lib64/ld-linux-x86-64.so.2 (0x00007f0ce4f12000)

        libnnz11.so => /oracle/client/11x_64/libnnz11.so (0x00007f0ce1146000)

        libnsl.so.1 => /lib64/libnsl.so.1 (0x00007f0ce0f2e000)

        libaio.so.1 => /lib64/libaio.so.1 (0x00007f0ce0d2b000)

     

     

    als User: ora<SID>

     

    brconnect -v

    BR0801I BRCONNECT 7.20 (35)


    0 0

    Team,

     

    I want to drop the unused tablespace including data files in Oracle 10.2.

    Our previous version of SAP & DB is SAP R/3 4.6C & Oracle  and upgraded to ERP 6.0 EHP4 & Oracle 10.2.0.2(last 2 yrs back)

     

    There was one old unused tablespace in my Database, it occupied the free space 40 GB. I want to drop this tablespace.

     

    Table space Name : PSAPSID46C

     

    Anybody Please find the attached screenhot for reference.

     

    I checked couple of times, drop that table space after that the oracle was down. I can't up the database.

     

    Give the correct solution. Plse help me.

     

    Thank You,

     

    Regards,

    A.Sithanandan


older | 1 | .... | 42 | 43 | (Page 44) | 45 | 46 | .... | 95 | newer